sitemn.gr domain is down

Incident Report for SiteManager

Resolved

The caching is working and the sites are back online. We are sorry for the inconvenience.
Posted Mar 10, 2026 - 23:14 CET

Monitoring

The nameservers are fixed by the greek registrar. Now we need to wait for the caching to pick up the changes.
Posted Mar 10, 2026 - 22:34 CET

Update

Our hosting partner Combell is in contact and waiting for the greek registrar to fix the nameservers. When this is done the problem will be resolved.
Posted Mar 10, 2026 - 22:13 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 10, 2026 - 19:15 CET

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 19:15 CET

Investigating

Our hosting partner is looking into the issue.
Posted Mar 10, 2026 - 19:14 CET
This incident affected: Hosted Websites and Dashboard & CMS.